• This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6079
    Webmaster
    Participant

    Our C70 plotter has failed in the middle of our cruise from Poole to N.Brittany and the Channel Islands in our Bavaria30. As we were preparing to leave Morlaix, when the C70 was switched on, the screen showed only a series of vertical lines, muticolourd with the ST60 on, monochrome without. I’ve tried page reset and factory reset as described in the manual and switched on and off several times to no avail. I had previously upgraded from software …425.pkg in April. We plan to stay in Morlaix for a few more days in the hope of finding a solution to enable us to continue our cruise with the safety of RADAR and the plotter. Could anyone please advise us of the possibilities for self repair,or by local agent; and shipment of any parts required.
    We bought the C70 last year with our new Bavaria 30.

    Keith & Jan Taylor, yacht ROMAH, Morlaix

    PS I’ve sent a similar request to Raymarine

    #7343
    Webmaster
    Participant

    Your C70 should still be under warranty so give Raymarine a call. They are normally very helpful.

    +44 (0) 23 9269 3611 and ask for technical support.

    Good luck

    Wayne

    #7346
    Webmaster
    Participant

    Thanks Wayne
    Raymarine were very helpful. Now the C70 has been sent by the chandler in Morlaix for repair under warranty by the Raymarine agent in France. Unfortunately this will take at least a week.

    Keith[/list]

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.