• This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #6562

      This is obviously not my year!! I recently relaunched and as I reached my mooring an alarm sounded but the engine was switched off before I could see the alarm detail. The engine shut off worked but now the panel is completely dead and as the boat is fitted with the newer electronic control system it is difficult to diagnose and of course I cannot start the engine. Has anyone come across this phenomenon please??



        The engine stop solenoid is wired so that it is energised for the engine to run and therefore any lack of power will automatically shut off the fuel.

        Is it possible that you have blown the main fuse and therefore lost all power to the panel and engine?


        Having thought about this more, do you mean the engine panel is dead or the main domesic panel in the saloon? If it is the engine panel, then it would be worth checking that a lead hasn’t fallen off the start battery or the earth lead off the engine?


          Thanks for the responses, next time I tried the engine the panel was working. Maybe there is some kind of auto reset?? However, after running for around 30 minutes the alarm sounded and I was able to identify it as the engine temp alarm. There is plenty of water coming out of the exhaust and the intercooler is hot to the touch so coolant is circulating any suggestions???


            If it really isn’t a real alarm (i.e. there isn’t some sort of localised overheating) it sounds as though there may be an intermittent wiring problem. These are often traced to poor earth returns.

            Which engine do you have – maybe we can find a wiring diagram on the web? Without that (and not owning a 31), I’d rather not speculate further.



              It looks as though the thermostat may be at fault, it is opening but perhaps not enough. I plan to try a new one which will hopefully sove the problem.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.